Описание программы

Программа предназначена для настройки параметров устройств, работающих в составе адресной системы "Рубеж".

Отличия версии 1.2:

1. Поддержка устройств:
- МПТ-1
- АМП-4
- ШУН
- ШУЗ

2. Возможность поиска сработавших устройств.

3. Добавлены горячие клавиши.


АМП-4

Для конфигурирования метки АМП-4 необходимо в выпадающем списке выбора устройства выбрать АМП-4 либо открыть файл с настройками метки. После чего появляется дерево параметров АМП-4, а также окно конфигурирования:

, где необходимо задать следующие параметры:

а) начальный адрес прибора записывается в параметр «Адрес» (всем четырем логическим приборам будут присвоены адреса в возрастающем порядке начиная с заданного адреса);
б) тип каждого ШС записывается в параметры «Шлейф 1», «Шлейф 2»,
«Шлейф 3», «Шлейф 4» соответственно каждому номеру ШС;
в) режим работы каждого транзисторного ключа записывается в параметры «Шлейф 1», «Шлейф 2», «Шлейф 3», «Шлейф 4» соответственно каждому номеру ШС.
В параметры «Шлейф 1», «Шлейф 2», «Шлейф3», «Шлейф 4» записывается двузначное число:
- первая цифра которого является типом ШС:
0 – (тип 0) шлейф дымовых датчиков с определением двойной сработки.
1 – (тип 1) комбинированный шлейф дымовых и тепловых датчиков: без определения двойной сработки тепловых датчиков и с определением двойной сработки дымовых.
2 - (тип 2) шлейф тепловых датчиков с определением двойной сработки.
3 – (тип 3) комбинированный шлейф дымовых и тепловых датчиков без определения двойной сработки и без контроля короткого замыкания ШС.
- вторая цифра значения параметров «Шлейф 1», «Шлейф 2», «Шлейф 3»,
«Шлейф 4» является режимом работы транзисторного ключа:
0 – не включать;
1 – переключается;
2 – включен постоянно;

Параметры ШС в различных состояниях приведены в таблице:


Запись/чтение параметров

Зная адрес, можно считать или записать параметры конфигурации устройства, отдельного или установленного в системе и подключенного к АЛС прибора приемно-контрольного.

Внимание: для корректной работы данной функции необходимо, чтобы в системе не была запущена программа FireSec. В противном случае будет выдано соответствующее предупреждение.

Для записи/чтения параметов устройства необходимо воспользоваться меню "Записать/считать параметры". При этом появляется окно "Запись/чтение параметров":

Окно содержит поля ввода для номера шлейфа и адреса устройства. Для записи/чтения параметров необходимо нажать соответствующую кнопку.
В случае неуспешного завершения в строке состояния появляется сообщение об ошибке:

В случае успешного чтения параметров появляется таблица, содержащая текущие параметры и параметры, считанные из устройства:

Красным подсвечиваются строки с несовпадающими параметрами.
Существует возможность заменить текущую конфигурацию на считанную либо сохранить считанную конфигурацию в файл.


МПТ-1

Для конфигурирования модуля МПТ-1 необходимо в выпадающем списке выбора устройства выбрать МПТ-1 либо открыть файл с настройками модуля. После чего появляется дерево параметров МПТ-1, а также окно конфигурирования, где необходимо задать следующие параметры:

а) адрес модуля МПТ – 1 (начальное значение адреса – 1.1);
б) статус модуля (ведущий или ведомый);
в) режим работы каждого релейного выхода;
г) логика работы каждого релейного выхода;
д) тип контроля цепей для релейного выхода;
е) значение нормального состояния датчиков «Масса», «Давление»,
«Двери-Окна»;
ж) временные параметры включения релейных выходов.

В программе эти параметры разделены на общие:

, и настройки релейных выходов:

На графике возможно изменять временные параметры работы выхода путем захвата мышью границ и перемещения их вдоль временной оси.

Параметры конфигурации модуля приведены в таблице:

№ параметра | Наименование | Диапазон возможных значений | Начальные значения | Примерные значения для ведомого
1 | Тип контроля выхода 1 | 1-4 | 4 | 4
2 | Тип контроля выхода 2 | 1-4 | 4 | 4
3 | Тип контроля выхода 3 | 1-4 | 4 | 4
4 | Тип контроля выхода 4 | 1-4 | 4 | 4
5 | Тип контроля выхода 5 | 1-4 | 4 | 4
6 | Значение нормального состояния датчика «Масса» | 1-2 | 2 | 2
7 | Значение нормального состояния датчика «Давление» | 1-2 | 2 | 2
8 | Значение нормального состояния датчика «Двери-Окна» | 1-2 | 1 | 2
9 | Статус МПТ (Ведущий/Ведомый) | 1-2 | 1 | 2
10 | Время включенного состояния выхода 1 | 0-255 | 2 | 2
11 | Время влюченного состояния выхода 2 | 0-255 | 2 | 2
12 | Время включенного состояния выхода 3 | 0-255 | 2 | 2
13 | Время включенного состояния выхода 4 | 0-255 | 2 | 2
14 | Время включенного состояния выхода 5 | 0-255 | 2 | 2
15 | Период переключения выхода 1 | 0-255 | 1 | 1
16 | Период переключения выхода 2 | 0-255 | 1 | 1
17 | Период переключения выхода 3 | 0-255 | 1 | 1
18 | Период переключения выхода 4 | 0-255 | 1 | 1
19 | Период переключения выхода 5 | 0-255 | 1 | 1
20 | Логика работы выхода 1 | 1-5 | 1 | 5
21 | Режим работы выхода 1 | 1-11 | 2 | 2
22 | Логика работы выхода 1 | 1-5 | 3 | 5
23 | Режим работы выхода 1 | 1-11 | 6 | 6
24 | Логика работы выхода 1 | 1-5 | 4 | 5
25 | Режим работы выхода 1 | 1-11 | 6 | 6
26 | Логика работы выхода 1 | 1-5 | 2 | 5
27 | Режим работы выхода 1 | 1-11 | 6 | 6
28 | Логика работы выхода 1 | 1-5 | 5 | 5
29 | Режим работы выхода 1 | 1-11 | 10 | 10

Параметры №1 - №5 (Тип контроля выхода).

Задаются одной цифрой, которая определяет контроль выхода:
1 - Состояние цепи не контролируется.
2 - Цепь контролируется только на обрыв.
3 - Цепь контролируется только на короткое замыкание.
4 - Цепь контролируется на короткое замыкание и на обрыв.
Для контроля цепей на короткое замыкание и обрыв непосредственно к нагрузке релейного выхода должны быть подключены диоды согласно схеме, приведенной на рисунке:

Rдоп = (U-1)/(0,06 - Iнагрузки) , где Iнагрузки = (U-1)/Rнагрузки , А
Rнагрузки – сопротивление исполнительного устройства, подключенного к релейному выходу, Ом;
U – напряжение релейного выхода;
При контроле цепей только на короткое замыкание – не устанавливается
диод VD*.
При контроле цепей только на обрыв – не устанавливается диод VD**.
Если состояние цепи не контролируется, то VD* и VD** не устанавливаются.
Состояния цепи определяется напряжением на минусовой клемме выхода относительно минусовой клеммы напряжения питания МПТ:
«Норма» – от 0,26 до 4,1 В.
«Обрыв» – более 4,2 В при выключенном выходе и менее 0,05 В при включенном.
«Короткое замыкание» – менее 0,25 В при выключенном выходе и более
4,5 В при включенном.
Для контроля состояния «Обрыв» во включенном состоянии выхода необходимо обеспечить протекание тока через нагрузку не менее 50 мА. Если цепь не контролируется на обрыв, то Rдоп можно не устанавливать.
Пример подключения светового оповещателя, рассчитанного на работу при напряжении12 В, приведен на рисунке:

Если цепь не контролируется на обрыв, то R** можно не устанавливать.

Параметры №6 - №8 (Значение нормального состояния датчика).

Число 1 или 2 определяет нормальное состояние датчика.
1 – нормальное состояние датчика – замкнутое;
2 – нормальное состояние датчика – разомкнутое.

Параметр №9 (Статус МПТ).

Число 1 или 2 определяет статус МПТ.
1 – ведущий,
2 – ведомый.
Ведомый, в отличие от ведущего, постоянно находится в режиме «Автоматика отключена».

Параметры №10 - №14

Время включенного состояния выходов 1-5 – 0…255 с.

Параметры №15 - №19

Период переключения выхода 1-5 – 0…255 с.

Параметры №20, №22, №24, №26, №28 (Логика работы выхода)

1 - Сирена.
2 - Табличка «Уходи».
3 - Табличка «Не входи».
4 - Табличка «Автоматика отключена».
5 - Выход АУП.
Режимы работы выходов с логикой работы «Выход АУП» не программируются и всегда соответствуют режиму работы 5. (Включить после паузы на заданное время и выключить ). Любое другое значение режима работы выхода с назначенной логикой работы «Выход АУП» будет игнорироваться.

Параметры №21, №23, №25, №27, №29 (Режим работы выхода)

1 - Не включать.
2 - Включить сразу.
3 - Включить после паузы.
4 - Включить на заданное время.
5 - Включить после паузы на заданное время и выключить.
6 - Переключать постоянно.
7 - Начать переключение после паузы.
8 - Переключать заданное время и оставить включенным.
9 - Начать переключение после паузы, переключать заданное время и оставить включенным.
10 - Переключать заданное время и оставить выключенным.
11 - Начать переключение после паузы, переключать заданное время и оставить выключенным.

Временные параметры включения релейных выходов.

Параметры №30 - №34

Время задержки включения выходов 1-5 – 0…255 с.

Управление режимом «Автоматика включена»

Три параметра значением 1 или 2 определяют следующие виды управления режимом:

Параметр №35 (Приоритет запуска)

1 - происходит останов отсчета задержки запуска при открытии дверей или окон (срабатывание датчика «Двери-Окна») и рестарт после закрытия дверей и окон.
2 - не происходит останов отсчета задержки запуска при срабатывании датчика «Двери-окна».

Параметр №36 (Блокировка отключения режима «Автоматика включена» при неисправности)

1 - режим «Автоматика включена» отключается при неисправности источника питания прибора, при неисправности ШС, при срабатывании датчика «Двери-Окна».
2 - режим «Автоматика включена» не отключается при неисправности источника питания прибора, при неисправности ШС, при срабатывании датчика «Двери-Окна».

Параметр №37 (Восстановление режима «Автоматика включена»)

1 - режим восстанавливается после восстановления датчика «Двери-Окна».
2 - режим не восстанавливается после восстановления датчика «Двери-Окна». Восстановление возможно ключом ТМ.


Настройка параметров

После выбора либо открытия файла появляется дерево параметров данного типа устройств, а также окно конфигурирования:

После настройки необходимых параметров их можно сохранить в файл (Меню "Файл -> Сохранить"), просмотреть в виде таблицы либо записать в устройство.


Начало работы

При запуске программы появляется главное окно:

Далее возможно либо выбрать устройство из предложенных

, либо открыть файл (*.config) с ранее сконфигурированными параметрами какого-либо устройства:

Возможно также открыть один из последних файлов:


Поиск устройств

В программе существует возможность поиска устройств. Для этого в окне "Запись/чтение параметров" необходимо нажать кнопку "Поиск устройств". При этом появляется окно поиска устройств:

Оказав воздействие на устройство (нажав на кнопку, на датчик вскрытия, осветив светодиод лазерной указкой), получаем тип и адрес данного устройства.
Поиск можно остановить, а затем начать заново. Найденные устройства отображаются в список:

Если выделить одно из найденных устройств и нажать кнопку "Выбрать" (либо двойной щелчок мыши на выбранном), то окно поиска закроется, а в окне "Запись/чтение параметров" в поля ввода запишутся адрес и номер шлейфа выбранного устройства.


Принцип работы

Программа поддерживает два режима работы: автономный и совместно с оборудованием.
При автономной работе возможно создание конфигураций параметров устройств, создание/открытие/редактирование файлов конфигурации (*.config), которые в дальнейшем можно будет записать в устройства.
При подключении устройств появляются дополнительные возможности: чтение текущих параметров из устройств и запись сконфигурированных параметров в устройства. Чтение/запись параметров производится в устройствах, подключенных к панели "Рубеж 2АМ". Панель соединена с ПК по USB. В RAM панели при этом загружается утилита, реализующий интерфейс для работы с устройствами.


Просмотр параметров

Параметры устройства можно просмотреть в виде таблицы, воспользовавшись меню "Действия -> Показать таблицу параметров". При этом появляется окно:

Для получения версии для печати необходимо нажать соответствующую кнопку.

Также возможно поместить таблицу параметров в буфер обмена, воспользовавшись сочетанием
клавиш Ctrl+A, Ctrl+C.


ШУЗ

Для конфигурирования шкафа ШУЗ необходимо в выпадающем списке выбора устройства выбрать ШУЗ либо открыть файл с настройками шкафа. После чего появляется дерево параметров ШУЗ, а также окно конфигурирования:

, где необходимо задать следующие параметры:
а) Время хода (1-65535 сек.)
б) Входы 2 и 4 (Нет, муфтовые выключатели, датчики уровня)
в) Вход 2 (норм. замкнут либо норм. разомкнут)
г) Вход 4 (норм. замкнут либо норм. разомкнут)
д) Концевой выключатель "открыто" (норм. замкнут либо норм. разомкнут)
е) Концевой выключатель "закрыто" (норм. замкнут либо норм. разомкнут)


ШУН

Для конфигурирования шкафа ШУН необходимо в выпадающем списке выбора устройства выбрать ШУН либо открыть файл с настройками шкафа. После чего появляется дерево параметров ШУН, а также окно конфигурирования:

Логика работы (тип, четыре младших бита адреса) ШУН зависит от состояния DIP-переключателя. Для каждого типа существует свой набор параметров. Необходимо выбрать тип и задать соответствующие параметры:

1..8 - Пожарный насос:
а) время выхода на режим (3-30 сек.)
б) время разновременного пуска (0-255 сек.)
в) датчик давления (норм. замкнут либо норм. разомкнут)

12 - Жокей насос и 13 - Компрессор
а) время восстановления давления (2-65535 мин.)
б) датчик давления (2х1 либо 1х2)
в) датчик давления "Пуск" (норм. замкнут либо норм. разомкнут)
г) датчик давления "Стоп" (норм. замкнут либо норм. разомкнут)

14 - Дренажный насос и 15 - НКУ
а) время восстановления уровня (2-65535 мин.)
б) датчик низкий уровня (норм. замкнут либо норм. разомкнут)
в) датчик высокий уровня (норм. замкнут либо норм. разомкнут)
г) датчик предельный уровня (норм. замкнут либо норм. разомкнут)